インストール

要件

  • Minimum Python version: 3.8.10

  • Dependencies: requests, py7zr, semantic_version, patch, texttable, bs4, defusedxml, humanize

pipコマンドによるインストール

Same as usual, it can be installed with pip

$ pip install aqtinstall

コマンドの変更

バージョン2.0.0から、サブコマンドが変更されました。これらのサブコマンドの以前のバージョンは、下位互換性のために保持されていますが、お勧めできません。

新しいサブコマンド

レガシーサブコマンド

Note

install-qt

install

バージョンはターゲットの後に移動しました

install-tool

tool

引数が変更されました

新しい構文はバージョンを使用しません

install-example

examples

バージョンはターゲットの後に移動しました

最後の引数に注意

install-src

src

バージョンはターゲットの後に移動しました

新しいコマンドは--kdeオプションしか使えません

install-doc

doc

バージョンはターゲットの後に移動しました

list

従来のリストコマンドは削除されました。

list-qt

list-tool